On Fri, 7 Dec 2012 11:06:34 +0900, Alex Courbot <acour...@nvidia.com> wrote: > On Thursday 06 December 2012 22:42:59 Grant Likely wrote: > > how about "gpio_chip_hwnum()" to somewhat match irqdomain convention? > > Sure, matching existing interfaces is better. "git grep hwnum" does not seem > to reveal much related to irqdomain though?
irqdomain actually uses "hwirq". "hwgpio" would be a closer analog than 'hwnum'. At first I though hwgpio to be too goofy, but on further reflection it probably has the least likelyhood of getting used incorrectly. g. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/