On Thu, 29 Nov 2012 15:43:08 -0800, Randy Dunlap <rdun...@infradead.org> wrote: > From: Randy Dunlap <rdun...@infradead.org> > > Fix build when CONFIG_W1_MASTER_GPIO=m by exporting "allnodes". > > ERROR: "allnodes" [drivers/w1/masters/w1-gpio.ko] undefined! > > Signed-off-by: Randy Dunlap <rdun...@infradead.org> > Cc: Ville Syrjala <syrj...@sci.fi> > --- > drivers/of/base.c | 1 + > 1 file changed, 1 insertion(+) > > --- linux-next-20121129.orig/drivers/of/base.c > +++ linux-next-20121129/drivers/of/base.c > @@ -46,6 +46,7 @@ struct alias_prop { > static LIST_HEAD(aliases_lookup); > > struct device_node *allnodes; > +EXPORT_SYMBOL(allnodes);
Makes sense, but I don't like exporting such a generic name. I'm picking up the patch but renaming s/allnodes/of_allnodes/ in the process. g. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/