On Thursday 16 August 2012, Chao Xie wrote:
> >> +     clocks[uart0_mux] =
> >> +         clk_register_mux(NULL, "uart0_mux", uart_parent,
> >> +                          ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT,
> >> +                          apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);


> i can change remove the clocks array, but even make the sentence
> shorter, most of them still can not fit in one line.

Don't worry too much about the line length or a particular style. This is
all about readability, and the style you use above may conform to some
written style guide, but it's not the most readable one. If you reformat
it to 

        clk = clk_register_mux(NULL, "uart0_mux", uart_parent, 
ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT, apbc_base + APBC_UART0, 4, 3, 0, 
&clk_lock);

or

        clk = clk_register_mux(NULL, "uart0_mux", uart_parent, 
ARRAY_SIZE(uart_parent),
                CLK_SET_RATE_PARENT, apbc_base + APBC_UART0, 4, 3, 0, 
&clk_lock);

or

        clk = clk_register_mux(NULL, "uart0_mux", uart_parent,
                 ARRAY_SIZE(uart_parent), CLK_SET_RATE_PARENT,
                 apbc_base + APBC_UART0, 4, 3, 0, &clk_lock);

I still find that more readable.

        Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to