On Tue, Aug 14, 2012 at 01:57:10AM +0900, JoonSoo Kim wrote: > > I think it would be better to just opencode system_wq selection in > > rebind_workers(). > > Sorry for my poor English skill. > Could you elaborate "opencode system_wq selection" means?
Dropping get_pool_system_wq() and putting the logic inside rebind_workers() directly. I tend to dislike short helpers which are used only once. They tend to obfuscate while not really contributing to anything else. Thanks. -- tejun -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/