On Wed, 18 Jul 2012 20:07:07 -0300 Rafael Aquini <aqu...@redhat.com> wrote:
> > > > > +} > > > +#else > > > +static inline bool is_balloon_page(struct page *page) { return > > > false; } > > > +static inline bool isolate_balloon_page(struct page *page) { return > > > false; } > > > +static inline bool putback_balloon_page(struct page *page) { return > > > false; } > > > +#endif /* (VIRTIO_BALLOON || VIRTIO_BALLOON_MODULE) && COMPACTION */ > > > > This means that if CONFIG_VIRTIO_BALLOON=y and CONFIG_COMPACTION=n, > > is_balloon_page() will always return NULL. IOW, no pages are balloon > > pages! This is wrong. > > > I believe it's right, actually, as we can see CONFIG_COMPACTION=n associated > with > CONFIG_MIGRATION=y (and CONFIG_VIRTIO_BALLOON=y). > For such config case we cannot perform the is_balloon_page() test branches > placed on mm/migration.c No, it isn't right. Look at the name: "is_balloon_page". If a caller runs is_balloon_page() against a balloon page with CONFIG_COMPACTION=n then they will get "false", which is incorrect. So the function needs a better name - one which communicates that it is a balloon page *for the purposes of processing by the compaction code*. Making the function private to compaction.c would help with that, if feasible. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/