> If another version is needed, you can rename counter to _counter to highlight > that the helpers should be used. > static void __hw_addr_count_add(struct netdev_hw_addr_list *list, int value) > Renaming struct netdev_hw_addr_list->count to _count would help to check all > users and highlight that modifying _count should be done with helpers.
Thanks, those suggestions make sense. I will adjust these in v9 if another version is needed.

