On Wed, Feb 13, 2008 at 12:06:21AM +0100, [EMAIL PROTECTED] wrote: > From: Marcin Slusarz <[EMAIL PROTECTED]> > > replace all: > big/little_endian_variable = > cpu_to_[bl]eX([bl]eX_to_cpu(big/little_endian_variable) + > expression_in_cpu_byteorder); > with: > [bl]eX_add_cpu(&big/little_endian_variable, > expression_in_cpu_byteorder); > generated with semantic patch
The patch looks correct to me, so ACK. > diff --git a/fs/sysv/sysv.h b/fs/sysv/sysv.h > index 42d51d1..38ebe3f 100644 > --- a/fs/sysv/sysv.h > +++ b/fs/sysv/sysv.h > @@ -217,9 +217,9 @@ static inline __fs32 fs32_add(struct sysv_sb_info *sbi, > __fs32 *n, int d) > if (sbi->s_bytesex == BYTESEX_PDP) > *(__u32*)n = PDP_swab(PDP_swab(*(__u32*)n)+d); > else if (sbi->s_bytesex == BYTESEX_LE) > - *(__le32*)n = cpu_to_le32(le32_to_cpu(*(__le32*)n)+d); > + le32_add_cpu((__le32 *)n, d); > else > - *(__be32*)n = cpu_to_be32(be32_to_cpu(*(__be32*)n)+d); > + be32_add_cpu((__be32 *)n, d); > return *n; but now that you've named the be and le primitives *_add_cpu it would be nice if you could submit a second patch to sysv to rename fs*_add to fs*_add_cpu aswell. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/