On 5 Aug 2026, at 23:34, Baolin Wang wrote:

> Implement mTHP-sized hugepage checking helpers using gather_folio_orders().
> Also rename the existing PMD-sized huge page check function to
> __check_pmd_huge() for clarity.
>
> Reviewed-by: Nico Pache (Red Hat) <[email protected]>
> Tested-by: Nico Pache (Red Hat) <[email protected]>
> Acked-by: Kiryl Shutsemau (Meta) <[email protected]>
> Signed-off-by: Baolin Wang <[email protected]>
> ---
>  tools/testing/selftests/mm/vm_util.c | 76 ++++++++++++++++++++++++++--
>  1 file changed, 72 insertions(+), 4 deletions(-)
>
LGTM.

Reviewed-by: Zi Yan <[email protected]>

Best Regards,
Yan, Zi

Reply via email to