On Wed, Jul 22, 2026 at 3:15 PM Joe Damato <[email protected]> wrote: > > On Wed, Jul 22, 2026 at 09:51:29AM +0800, longlong yan wrote: > > mmap() is documented to return MAP_FAILED on error, but tcp_mmap.c > > compares the return value against (void *)-1 and (unsigned char *)-1. > > > > Replace these with the standard MAP_FAILED macro for better readability > > and type safety. > > > > Signed-off-by: longlong yan <[email protected]> > > --- > > tools/testing/selftests/net/tcp_mmap.c | 10 +++++----- > > 1 file changed, 5 insertions(+), 5 deletions(-) > > > > Looks right to me. Not sure if it needs to be set with "net-next" in the > subject line to make which tree this targets more explicit? > > Either way: > > Reviewed-by: Joe Damato <[email protected]>
Yeah, I doubt linux will ever use a different value than (void *)-1 for MAP_FAILED. Reviewed-by: Eric Dumazet <[email protected]>

