On 2026-07-01 at 19:05 +1000, Li Zhe <[email protected]> wrote...
> memmap_init_zone_device() repeats nearly identical head-page
> initialization for each PFN. Prepare one reusable ZONE_DEVICE head-page
> template through the existing slow path, refresh the PFN-dependent
> fields in that template before each copy, and memcpy it into each
> destination page.
>
> The optimized path assigns _refcount through the copied template, so
> keep it disabled when the page_ref_set tracepoint is enabled.
>
> This patch accelerates head-page initialization. The pfns_per_compound
> == 1 case gets the full benefit here, compound tails are handled in the
> next patch.
>
> Tested in a VM with a 100 GB fsdax namespace device configured with
> map=dev on Intel Ice Lake server. This test exercises the nd_pmem rebind
> path (pfns_per_compound == 1).
>
> Test procedure:
> Rebind the nd_pmem driver 30 times and collect the memmap initialization
> time from the pr_debug() output of memmap_init_zone_device().
>
> Base(v7.2-rc1):
> First binding: 1456 ms
> Average of subsequent rebinds: 244.28 ms
>
> With this patch and its prerequisites applied:
> First binding: 1440 ms
> Average of subsequent rebinds: 217.19 ms
>
> This reduces the average rebind time from 244.28 ms to 217.19 ms, or
> about 11%.
>
> Signed-off-by: Li Zhe <[email protected]>
> ---
> mm/mm_init.c | 76 ++++++++++++++++++++++++++++++++++++++++++++++++++--
> 1 file changed, 74 insertions(+), 2 deletions(-)
>
> diff --git a/mm/mm_init.c b/mm/mm_init.c
> index 4c7fad440c2a..cc8417951467 100644
> --- a/mm/mm_init.c
> +++ b/mm/mm_init.c
> @@ -1066,6 +1066,50 @@ static void __ref zone_device_page_init_slow(struct
> page *page,
> set_page_count(page, 0);
> }
>
> +static inline bool zone_device_page_init_optimization_enabled(void)
> +{
> + /*
> + * The template fast path copies a preinitialized struct page image.
> + * Skip it when the page_ref_set tracepoint is enabled.
> + */
> + return !page_ref_tracepoint_active(page_ref_set);
> +}
> +
> +static inline void zone_device_template_page_init(struct page *template,
> + struct page *src)
> +{
> + memcpy(template, src, sizeof(*template));
I'd drop this function and just open-code the memcpy as I think that ends up
being clearer and removes a naming confusion - I kept mixing up the purpose of
`zone_device_template_page_init` and `zone_device_page_init_from_template`
> +}
> +
> +/*
> + * 'template' is a reusable page prototype rather than a strictly immutable
> + * object. Most ZONE_DEVICE fields stay constant across the pages covered by
> + * the current template, but section bits and page->virtual may still depend
> + * on the PFN. Refresh those PFN-dependent fields in the template before
> + * copying it into @page.
> + */
> +static inline void zone_device_page_update_template(struct page *template,
> + unsigned long pfn)
> +{
> + set_page_section_from_pfn(template, pfn);
> +#ifdef WANT_PAGE_VIRTUAL
> + if (!is_highmem_idx(ZONE_DEVICE))
> + set_page_address(template, __va(pfn << PAGE_SHIFT));
> +#endif
> +}
> +
> +static void zone_device_page_init_from_template(struct page *page,
> + unsigned long pfn, struct page *template)
> +{
> + /*
> + * 'template' carries the invariant portion of a ZONE_DEVICE struct
> + * page. Update the PFN-dependent fields in place before copying it
> + * to the destination page.
> + */
> + zone_device_page_update_template(template, pfn);
> + memcpy(page, template, sizeof(*page));
> +}
> +
> /*
> * With compound page geometry and when struct pages are stored in ram most
> * tail pages are reused. Consequently, the amount of unique struct pages to
> @@ -1121,6 +1165,7 @@ void __ref memmap_init_zone_device(struct zone *zone,
> unsigned long nr_pages,
> struct dev_pagemap *pgmap)
> {
> + bool use_template = zone_device_page_init_optimization_enabled();
> unsigned long pfn, end_pfn = start_pfn + nr_pages;
> struct pglist_data *pgdat = zone->zone_pgdat;
> struct vmem_altmap *altmap = pgmap_altmap(pgmap);
> @@ -1128,6 +1173,7 @@ void __ref memmap_init_zone_device(struct zone *zone,
> unsigned long zone_idx = zone_idx(zone);
> unsigned long start = jiffies;
> int nid = pgdat->node_id;
> + struct page template;
>
> if (WARN_ON_ONCE(!pgmap || zone_idx != ZONE_DEVICE))
> return;
> @@ -1142,10 +1188,36 @@ void __ref memmap_init_zone_device(struct zone *zone,
> nr_pages = end_pfn - start_pfn;
> }
>
> - for (pfn = start_pfn; pfn < end_pfn; pfn += pfns_per_compound) {
> - struct page *page = pfn_to_page(pfn);
> +
> + if (!nr_pages)
> + return;
> +
> + pfn = start_pfn;
> + /*
> + * Seed the reusable head-page template from the first real struct
> + * page, because the existing page-init and pageblock helpers expect
> + * a real memmap entry rather than a stack object.
> + */
> + if (use_template) {
> + struct page *page = pfn_to_page(start_pfn);
>
> zone_device_page_init_slow(page, pfn, zone_idx, nid, pgmap);
> + zone_device_template_page_init(&template, page);
> + if (pfns_per_compound != 1)
> + memmap_init_compound(page, pfn, zone_idx, nid, pgmap,
> + compound_nr_pages(start_pfn, altmap, pgmap));
> + pfn += pfns_per_compound;
I think it would be clearer and less error prone to not unroll the loop here.
Instead just initialise the template page and leave the for loop starting at
pfn = start_pfn and let it handle the rest of the steps. I can't imagine the
extra call to zone_deivce_page_init_from_template() would cause a noticable
perf impact.
It also avoids the obvious danger of someone updating the loop but missing the
unrolled version above.
- Alistair
> + }
> +
> + for (; pfn < end_pfn; pfn += pfns_per_compound) {
> + struct page *page = pfn_to_page(pfn);
> +
> + if (use_template)
> + zone_device_page_init_from_template(page, pfn,
> + &template);
> + else
> + zone_device_page_init_slow(page, pfn, zone_idx,
> + nid, pgmap);
>
> if (IS_ALIGNED(pfn, PAGES_PER_SECTION))
> cond_resched();
> --
> 2.20.1