On Sat, Jul 04, 2026 at 01:08:13AM +0530, Mukesh Ojha wrote: > Drivers using of_reserved_mem_device_init() and its variants must > manually call of_reserved_mem_device_release() in their remove and > error-unwind paths. This is repetitive boilerplate that is easy to > get wrong, and several drivers have open-coded the teardown > inconsistently or skipped it entirely, leading to dangling reserved > memory references.
Just as a general thing, rather than sending a huge cross subsystem series for something like this it's probably better to just send a couple of examples, then once the new API is introduced and either has a pullable tag or has made it to mainline go and do the conversion. This avoids clogging everyone's inbox with very big serieses.
signature.asc
Description: PGP signature

