On Saturday 02 February 2008 08:16, Philip Langdale wrote: > Again, thanks a lot for investigating and finding the appropriate magic > incantations. My main comment is to please base this on top of my > suspend/resume > patch which Pierre said he accepted but which isn't in his tree yet - I guess > he's busy offline right now - haven't heard from him in a while.
Yes, sorry, in the meantime i saw your suspend/resume patch .. will rebase this on it, but also due to being a bit bussy now probably not until beginning of next week. > > struct pci_dev *fw_dev = NULL; > > + struct pci_dev *main_dev = NULL; /* for Ricoh RL5c476 II */ > > There's no need to have two pointers. One will do fine. yes, fully agree .. > It feels like there's a bit too much code duplication going on here, but I > think > that after you rebase the patch it'll look a lot tidier and I won't feel bad > about > it :-) yes, also fully agree .. sadfully i was in a bit of a hurry that day needing a working patch for a internal deadline. > > - struct pci_dev *fw_dev = NULL; > > + struct pci_dev *ctrl_dev = NULL; > > Same as in probe. Just use one pointer. Hehe, no, not here ... its "-", "+" ;-) Thanks, Frank -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/