On Tue, Dec 3, 2024 at 12:11 AM Peter Zijlstra <pet...@infradead.org> wrote:
Please add a commit description. > > Signed-off-by: Peter Zijlstra (Intel) <pet...@infradead.org> > --- > scripts/mod/modpost.c | 7 ++----- > 1 file changed, 2 insertions(+), 5 deletions(-) > > --- a/scripts/mod/modpost.c > +++ b/scripts/mod/modpost.c > @@ -1586,12 +1586,9 @@ static void read_symbols(const char *mod > license = get_next_modinfo(&info, "license", license); > } > > - namespace = get_modinfo(&info, "import_ns"); > - while (namespace) { > + for (namespace = get_modinfo(&info, "import_ns"); namespace; > + namespace = get_next_modinfo(&info, "import_ns", > namespace)) [Bikeshed] Personally, I tend to indent a long for() as follows: for (namespace = get_modinfo(&info, "import_ns"); namespace; namespace = get_next_modinfo(&info, "import_ns", namespace)) > add_namespace(&mod->imported_namespaces, namespace); > - namespace = get_next_modinfo(&info, "import_ns", > - namespace); > - } > > if (extra_warn && !get_modinfo(&info, "description")) > warn("missing MODULE_DESCRIPTION() in %s\n", modname); > > -- Best Regards Masahiro Yamada