On Thu, Jan 23, 2025 at 09:54:38AM +0000, Tian, Kevin wrote:
> > From: Nicolin Chen <nicol...@nvidia.com>
> > Sent: Saturday, January 11, 2025 11:32 AM
> > 
> > @@ -224,8 +224,10 @@ struct iommu_domain {
> >                   phys_addr_t msi_addr);
> >  #endif
> > 
> > -   void *fault_data;
> > -   union {
> > +   union { /* Pointer usable by owner of the domain */
> > +           struct iommufd_hw_pagetable *iommufd_hwpt; /* iommufd
> > */
> > +   };
> > +   union { /* Fault handler */
> 
> hmm is it better to rename it as "void *private;" and let the caller
> do type conversion?

I like the type safety, the union can hold other in-kernel users with
their proper types and this discourages drivers from inventing weird
things..

Jason

Reply via email to