On 19/04/21 08:59, Phil Auld wrote: > On Fri, Apr 16, 2021 at 10:43:38AM +0100 Valentin Schneider wrote: >> On 15/04/21 16:39, Rik van Riel wrote: >> > On Thu, 2021-04-15 at 18:58 +0100, Valentin Schneider wrote: >> >> @@ -7672,6 +7698,15 @@ int can_migrate_task(struct task_struct *p, >> >> struct lb_env *env) >> >> if (tsk_cache_hot == -1) >> >> tsk_cache_hot = task_hot(p, env); >> >> >> >> + /* >> >> + * On a (sane) asymmetric CPU capacity system, the increase in >> >> compute >> >> + * capacity should offset any potential performance hit caused >> >> by a >> >> + * migration. >> >> + */ >> >> + if ((env->dst_grp_type == group_has_spare) && >> >> + !migrate_degrades_capacity(p, env)) >> >> + tsk_cache_hot = 0; >> > >> > ... I'm starting to wonder if we should not rename the >> > tsk_cache_hot variable to something else to make this >> > code more readable. Probably in another patch :) >> > >> >> I'd tend to agree, but naming is hard. "migration_harmful" ? > > I thought Rik meant tsk_cache_hot, for which I'd suggest at least > buying a vowel and putting an 'a' in there :) >
That's the one I was eyeing: s/tsk_cache_hot/migration_harmful/ or somesuch. Right now we're feeding it: o migrate_degrades_locality() o task_hot() and I'm adding another one, so that's 2/3 which don't actually care about cache hotness, but rather "does doing this migration degrade/improve $criterion?"