On 3/12/21 3:13 PM, Catalin Marinas wrote: > On Fri, Mar 12, 2021 at 02:22:07PM +0000, Vincenzo Frascino wrote: >> diff --git a/arch/arm64/include/asm/mte.h b/arch/arm64/include/asm/mte.h >> index 9b557a457f24..8603c6636a7d 100644 >> --- a/arch/arm64/include/asm/mte.h >> +++ b/arch/arm64/include/asm/mte.h >> @@ -90,5 +90,20 @@ static inline void mte_assign_mem_tag_range(void *addr, >> size_t size) >> >> #endif /* CONFIG_ARM64_MTE */ >> >> +#ifdef CONFIG_KASAN_HW_TAGS >> +/* Whether the MTE asynchronous mode is enabled. */ >> +DECLARE_STATIC_KEY_FALSE(mte_async_mode); >> + >> +static inline bool system_uses_mte_async_mode(void) >> +{ >> + return static_branch_unlikely(&mte_async_mode); >> +} >> +#else >> +static inline bool system_uses_mte_async_mode(void) >> +{ >> + return false; >> +} >> +#endif /* CONFIG_KASAN_HW_TAGS */ > > You can write this with fewer lines: > > DECLARE_STATIC_KEY_FALSE(mte_async_mode); > > static inline bool system_uses_mte_async_mode(void) > { > return IS_ENABLED(CONFIG_KASAN_HW_TAGS) && > static_branch_unlikely(&mte_async_mode); > } > > The compiler will ensure that mte_async_mode is not referred when > !CONFIG_KASAN_HW_TAGS and therefore doesn't need to be defined. >
Yes, I agree, but I introduce "#ifdef CONFIG_KASAN_HW_TAGS" in the successive patch anyway, according to me the overall code looks more uniform like this. But I do not have a strong opinion or preference on this. >> diff --git a/arch/arm64/kernel/mte.c b/arch/arm64/kernel/mte.c >> index fa755cf94e01..9362928ba0d5 100644 >> --- a/arch/arm64/kernel/mte.c >> +++ b/arch/arm64/kernel/mte.c >> @@ -26,6 +26,10 @@ u64 gcr_kernel_excl __ro_after_init; >> >> static bool report_fault_once = true; >> >> +/* Whether the MTE asynchronous mode is enabled. */ >> +DEFINE_STATIC_KEY_FALSE(mte_async_mode); >> +EXPORT_SYMBOL_GPL(mte_async_mode); > > Maybe keep these bracketed by #ifdef CONFIG_KASAN_HW_TAGS. I think the > mte_enable_kernel_*() aren't needed either if KASAN_HW is disabled (you > can do it with an additional patch). > Makes sense, I will add it in the next version. > With these, you can add: > > Reviewed-by: Catalin Marinas <catalin.mari...@arm.com> > -- Regards, Vincenzo