Anshuman Khandual <[email protected]> writes: > SYS_SUPPORTS_HUGETLBFS config has duplicate definitions on platforms that > subscribe it. Instead, just make it a generic option which can be selected > on applicable platforms. Also rename it as ARCH_SUPPORTS_HUGETLBFS instead. > This reduces code duplication and makes it cleaner. > > Cc: Russell King <[email protected]> > Cc: Catalin Marinas <[email protected]> > Cc: Will Deacon <[email protected]> > Cc: Thomas Bogendoerfer <[email protected]> > Cc: "James E.J. Bottomley" <[email protected]> > Cc: Helge Deller <[email protected]> > Cc: Michael Ellerman <[email protected]> > Cc: Benjamin Herrenschmidt <[email protected]> > Cc: Paul Mackerras <[email protected]> > Cc: Paul Walmsley <[email protected]> > Cc: Palmer Dabbelt <[email protected]> > Cc: Albert Ou <[email protected]> > Cc: Yoshinori Sato <[email protected]> > Cc: Rich Felker <[email protected]> > Cc: Alexander Viro <[email protected]> > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Cc: [email protected] > Signed-off-by: Anshuman Khandual <[email protected]> > --- > arch/arm/Kconfig | 5 +---- > arch/arm64/Kconfig | 4 +--- > arch/mips/Kconfig | 6 +----- > arch/parisc/Kconfig | 5 +---- > arch/powerpc/Kconfig | 3 --- > arch/powerpc/platforms/Kconfig.cputype | 6 +++---
Acked-by: Michael Ellerman <[email protected]> (powerpc) cheers

