On Wed, 2008-01-09 at 09:45 +1100, Paul Mackerras wrote: > Harvey Harrison writes: > > > Use a central is_kprobe_fault() inline in kprobes.h to remove all > > of the arch-dependant, practically identical implementations in > > avr32, ia64, powerpc, s390, sparc64, and x86. > > I don't like the name "is_kprobe_fault" since the function actually > handles the fault - i.e. it does more than just tell the caller > whether this is a kprobes fault. Something like > "handle_kprobes_fault" or "maybe_handle_kprobes_fault" would be > better IMO.
Good point, I chose the name based simply on the usage pattern found in all the callers. Of your suggestions I like handle_kprobes_fault better. How about check_kprobes_fault? That seems to cover what you were getting at with maybe_handle_kprobes_fault but is shorter. That also fits better with the !CONFIG_KPROBES case. Harvey -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/