On 1/18/21 11:14 AM, Andy Shevchenko wrote:
But isn't it good to expose those issues (and fix them)?
I suppose.

Perhaps even add _ADDRESS to DUMP_PREFIX_UNHASHED, but this maybe too
long.

I think DUMP_PREFIX_ADDRESS_UNHASHED is too long.
What about introducing new two like these:

        DUMP_PREFIX_OFFSET,
        DUMP_PREFIX_ADDRESS,
        DUMP_PREFIX_ADDR_UNHASHED,
        DUMP_PREFIX_ADDR_HASHED,
I think we're approaching bike-shedding.  DUMP_PREFIX_ADDR_HASHED and 
DUMP_PREFIX_ADDRESS are the same thing.
I don't want people to have to move from DUMP_PREFIX_ADDRESS to some 
other enum for no change in functionality.  I'm willing to rearrange the 
code so that it's enumerated more consistently, but I don't think 
there's anything wrong with DUMP_PREFIX_UNHASHED.  It's succinct and clear.


Reply via email to