Hi Vinod,
On Tue, Jan 12, 2021 at 11:19 AM Vinod Koul <[email protected]> wrote:
> On 07-01-21, 19:15, Geert Uytterhoeven wrote:
> > Add and helper macro for iterating over all DMAC channels, taking into
> > account the channel mask. Use it where appropriate, to simplify code.
> >
> > Restore "reverse Christmas tree" order of local variables while adding a
> > new variable.
> >
> > Signed-off-by: Geert Uytterhoeven <[email protected]>
> > --- a/drivers/dma/sh/rcar-dmac.c
> > +++ b/drivers/dma/sh/rcar-dmac.c
> > @@ -209,6 +209,11 @@ struct rcar_dmac {
> >
> > #define to_rcar_dmac(d) container_of(d, struct rcar_dmac,
> > engine)
> >
> > +#define for_each_rcar_dmac_chan(i, chan, dmac)
> > \
> > + for (i = 0, chan = &(dmac)->channels[0]; i < (dmac)->n_channels; \
> > + i++, chan++) \
>
> single line to make it more readable? we have limit of 100 now :)
Do we have to push the limits?
BTW, the new punched cards are 96-column wide, not 100-column ;-)
https://en.wikipedia.org/wiki/Punched_card#IBM_96-column_format
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds