Hi Linus, On Sat, Oct 31, 2020 at 8:51 PM Linus Torvalds <torva...@linux-foundation.org> wrote: > On Sat, Oct 31, 2020 at 2:40 AM Christoph Hellwig <h...@infradead.org> wrote: > > dma-mapping fix for 5.10: > > > > - fix an integer overflow on 32-bit platforms in the new DMA range code > > (Geert Uytterhoeven) > > So this is just a stylistic nit, and has no impact on this pull (which > I've done). But looking at the patch, it triggers one of my "this is > wrong" patterns. > > In particular, this: > > u64 dma_start = 0; > ... > for (dma_start = ~0ULL; r->size; r++) { > > is actually completely bogus in theory, and it's a horribly horribly > bad pattern to have. > > The thing that I hate about that parttern is "~0ULL", which is simply wrong. > > The correct pattern for "all bits set" is ~0. NOTHING ELSE. No extra > letters at the end. > > Why? Because using an unsigned type is wrong, and will not extend the > bits up to a potentially bigger size. > > So adding that "ULL" is not just three extra characters to type, it > actually _detracts_ from the code and makes it more fragile and > potentially wrong. > > It so happens, that yes, in the kernel, "ull" us 64-bit, and you get > the right results. So the code _works_. But it's wrong, and it now > requires that the types match exactly (ie it would not be broken if > somebody ever were to say "I want to use use 128-bit dma addresses and > u128").
Thanks, you're right, the "ULL" suffix is not needed, and could cause future issues. > Another example is using "~0ul", which would give different results on > a 32-bit kernel and a 64-bit kernel. Again: DON'T DO THAT. Definitely. > I repeat: the right thing to do for "all bits set" is just a plain ~0 > or -1. Either of those are fine (technically assumes a 2's complement > machine, but let's just be honest: that's a perfectly fine assumption, > and -1 might be preferred by some because it makes that sign extension > behavior of the integer constant more obvious). "-1" definitely causes warnings, depending on your compiler (not with the gcc 9.3.0 I'm currently using, though). > Don't try to do anything clever or anything else, because it's going > to be strictly worse. > > The old code that that patch removed was "technically correct", but > just pointless, and actually shows the problem: > > for (dma_start = ~(dma_addr_t)0; r->size; r++) { > > the above is indeed a correct way to say "I want all bits set in a > dma_addr_t", but while correct, it is - once again - strictly inferior > to just using "~0". Obviously I was misled by the old code, and instead of changing the cast, I replaced the cast ("casts are evil") by a suffix. Doh. Any, I've just sent a patch. Thanks! Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds