On 2020/07/15 10:22, Tetsuhiro Kohada wrote:
Add validation for num, bh and type on getting dir-entry. ('file' and 'stream-ext' dir-entries are pre-validated to ensure success) Renamed exfat_get_dentry_cached() to exfat_get_validated_dentry() due to a change in functionality.Integrate type-validation with simplified. This will also recognize a dir-entry set that contains 'benign secondary' dir-entries. And, rename TYPE_EXTEND to TYPE_NAME. Suggested-by: Sungjong Seo <[email protected]> Signed-off-by: Tetsuhiro Kohada <[email protected]> --- Changes in v2 - Change verification order - Verification loop start with index 2
Ping. Is there anything I should do? BR --- Tetsuhiro Kohada <[email protected]>

