Use USEC_PER_SEC instead of magic numbers to make code more readable. Signed-off-by: Baolin Wang <baolin.w...@linux.alibaba.com> --- drivers/nvme/host/core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c index c3a60d8..0eca820 100644 --- a/drivers/nvme/host/core.c +++ b/drivers/nvme/host/core.c @@ -2963,7 +2963,7 @@ int nvme_init_identify(struct nvme_ctrl *ctrl) if (id->rtd3e) { /* us -> s */ - u32 transition_time = le32_to_cpu(id->rtd3e) / 1000000; + u32 transition_time = le32_to_cpu(id->rtd3e) / USEC_PER_SEC; ctrl->shutdown_timeout = clamp_t(unsigned int, transition_time, shutdown_timeout, 60); -- 1.8.3.1