The logic in attach_page_buffers and __clear_page_buffers are quite paired, but
1. they are located in different files. 2. attach_page_buffers is implemented in buffer_head.h, so it could be used by other files. But __clear_page_buffers is static function in buffer.c and other potential users can't call the function, md-bitmap even copied the function. So, introduce the new attach/detach_page_private to replace them. With the new pair of function, we will remove the usage of attach_page_buffers and __clear_page_buffers in next patches. Thanks for suggestions about the function name from Alexander Viro, Andreas Grünbacher, Christoph Hellwig and Matthew Wilcox. Suggested-by: Matthew Wilcox <wi...@infradead.org> Cc: Andrew Morton <a...@linux-foundation.org> Cc: linux...@kvack.org Cc: "Darrick J. Wong" <darrick.w...@oracle.com> Cc: William Kucharski <william.kuchar...@oracle.com> Cc: "Kirill A. Shutemov" <kirill.shute...@linux.intel.com> Cc: Andreas Gruenbacher <agrue...@redhat.com> Cc: Yang Shi <yang....@linux.alibaba.com> Cc: Yafang Shao <laoar.s...@gmail.com> Cc: Song Liu <s...@kernel.org> Cc: linux-r...@vger.kernel.org Cc: Chris Mason <c...@fb.com> Cc: Josef Bacik <jo...@toxicpanda.com> Cc: David Sterba <dste...@suse.com> Cc: linux-bt...@vger.kernel.org Cc: Alexander Viro <v...@zeniv.linux.org.uk> Cc: Jaegeuk Kim <jaeg...@kernel.org> Cc: Chao Yu <c...@kernel.org> Cc: linux-f2fs-de...@lists.sourceforge.net Cc: Christoph Hellwig <h...@infradead.org> Cc: linux-...@vger.kernel.org Cc: Anton Altaparmakov <an...@tuxera.com> Cc: linux-ntfs-...@lists.sourceforge.net Cc: Mike Marshall <hub...@omnibond.com> Cc: Martin Brandenburg <mar...@omnibond.com> Cc: de...@lists.orangefs.org Cc: Thomas Gleixner <t...@linutronix.de> Cc: Sebastian Andrzej Siewior <bige...@linutronix.de> Cc: Roman Gushchin <g...@fb.com> Cc: Andreas Dilger <adil...@dilger.ca> Signed-off-by: Guoqing Jiang <guoqing.ji...@cloud.ionos.com> --- RFC V2 -> RFC V3: 1. rename clear_page_private to detach_page_private. 2. updated the comments for the two functions. RFC -> RFC V2: Address the comments from Christoph Hellwig 1. change function names to attach/clear_page_private and add comments. 2. change the return type of attach_page_private. include/linux/pagemap.h | 37 +++++++++++++++++++++++++++++++++++++ 1 file changed, 37 insertions(+) diff --git a/include/linux/pagemap.h b/include/linux/pagemap.h index a8f7bd8ea1c6..99dd93188a5e 100644 --- a/include/linux/pagemap.h +++ b/include/linux/pagemap.h @@ -205,6 +205,43 @@ static inline int page_cache_add_speculative(struct page *page, int count) return __page_cache_add_speculative(page, count); } +/** + * attach_page_private - Attach private data to a page. + * @page: Page to attach data to. + * @data: Data to attach to page. + * + * Attaching private data to a page increments the page's reference count. + * The data must be detached before the page will be freed. + */ +static inline void attach_page_private(struct page *page, void *data) +{ + get_page(page); + set_page_private(page, (unsigned long)data); + SetPagePrivate(page); +} + +/** + * detach_page_private - Detach private data from a page. + * @page: Page to detach data from. + * + * Removes the data that was previously attached to the page and decrements + * the refcount on the page. + * + * Return: Data that was attached to the page. + */ +static inline void *detach_page_private(struct page *page) +{ + void *data = (void *)page_private(page); + + if (!PagePrivate(page)) + return NULL; + ClearPagePrivate(page); + set_page_private(page, 0); + put_page(page); + + return data; +} + #ifdef CONFIG_NUMA extern struct page *__page_cache_alloc(gfp_t gfp); #else -- 2.17.1