On Fri, Aug 10, 2007 at 04:22:09PM +0200, Andreas Gruenbacher wrote:
> * Add pathput() for releasing a reference to the dentry and vfsmount of a
>   struct path.
> 
> * Switch from path_release(nd) to pathget(&nd->path).

                                ^^^^^^^^^^^^^ pathput

> 
> * Switch from path_release_on_umount(nd) to pathput_on_umount(&nd->path).
> 
> * Rename dput_path() to pathput_conditional().

The introduction of pathput is fine we me.  The removal of path_release
doesn't make much sense.  We have tons of invocations of exactly that
patter, and having keeping path_release for that makes a lot of sense.

I also think there rename from dput_path to pathput_conditional is
rather pointless.  Sure, that thing needs a better name, but
pathput_conditional is not a better name.

And all of the functions could use some kerneldoc comments describing them.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to