Checkpatch suggests to place a parenthesis around this complex macro. Signed-off-by: Nicholas Mc Guire <hof...@osadl.org> ---
Problem reported by checkpatch I'm actually not sure this really is improving readability but by default checkpatch gets it right so... Patch was compile-tested with: imx_v4_v5_defconfig (implies CONFIG_MACH_MX27ADS=y) Patch is against 5.1-rc4 (localversion-next is 20190412) arch/arm/mach-imx/mach-mx27ads.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-imx/mach-mx27ads.c b/arch/arm/mach-imx/mach-mx27ads.c index 49ac898..c83fdd3 100644 --- a/arch/arm/mach-imx/mach-mx27ads.c +++ b/arch/arm/mach-imx/mach-mx27ads.c @@ -42,8 +42,8 @@ * Base address of PBC controller, CS4 */ #define PBC_BASE_ADDRESS 0xf4300000 -#define PBC_REG_ADDR(offset) (void __force __iomem *) \ - (PBC_BASE_ADDRESS + (offset)) +#define PBC_REG_ADDR(offset) ((void __force __iomem *) \ + (PBC_BASE_ADDRESS + (offset))) /* When the PBC address connection is fixed in h/w, defined as 1 */ #define PBC_ADDR_SH 0 -- 2.1.4