On 13-Mar 18:22, Peter Zijlstra wrote:
> On Wed, Mar 13, 2019 at 04:12:29PM +0000, Patrick Bellasi wrote:
> > Yes, the for looks better, but perhaps like that:
> > 
> >     unsigned int bucket_id = UCLAMP_BUCKETS;
> > 
> >     /*
> >      * Both min and max clamps are MAX aggregated, thus the topmost
> >      * bucket with some tasks defines the rq's clamp value.
> >      */
> >     for (; bucket_id >= 0; --bucket_id) {
> 
> GCC will be clever and figure that unsigned will never be smaller than 0
> and turn the above into an infinite loop or something daft.
> 
> That is; use 'int', not 'unsigned int' for bucket_id.

Right, which remembers me now why I originally went for a do { } while();

-- 
#include <best/regards.h>

Patrick Bellasi

Reply via email to