On Mon, 06 Aug 2007 11:14:03 +0100 David Vrabel <[EMAIL PROTECTED]> wrote:
> > I really don't follow you objection to this. If one is maintaining > the SDIO core then I would expect some familiarity with the spec and > an understanding the FBRs are per-function but contained in the same > CCCR/F0 register space. > If we can reduce that barrier, then I think we should. People can't be expected to keep everything fresh in memory all the time. And we won't have a team dedicated to hacking this all the time. > Also, I would consider the start of the CCCR as the "base address". > In some sense, but there are also several identical FBR chunks on the card. So by most definitions of a base address, the start of each chunk would be it. > > Would you be content with replacing "func->num * 0x100" with a > > macro so that the code becomes something like: > > > > SDIO_FBR_BASE(func->num) + SDIO_FBR_STD_IF > > I think this is less readable than SDIO_FBR_STD_IF(func->num). > It's subjective. But the longer version is more understandable for someone who doesn't have the details of the SDIO protocol fresh in his mind. Rgds -- -- Pierre Ossman Linux kernel, MMC maintainer http://www.kernel.org PulseAudio, core developer http://pulseaudio.org rdesktop, core developer http://www.rdesktop.org - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/