On Mon, Dec 17, 2018 at 5:58 AM Bjorn Helgaas <helg...@kernel.org> wrote: > > On Sun, Dec 16, 2018 at 03:09:16PM -0800, Andrey Smirnov wrote: > > Convert all fallthrough comments to say "fall through", as well as > > modify their placement to the point where the "break" would normally > > be. > > > > Cc: Bjorn Helgaas <bhelg...@google.com> > > Cc: Fabio Estevam <fabio.este...@nxp.com> > > Cc: Chris Healy <cphe...@gmail.com> > > Cc: Lucas Stach <l.st...@pengutronix.de> > > Cc: Leonard Crestez <leonard.cres...@nxp.com> > > Cc: "A.s. Dong" <aisheng.d...@nxp.com> > > Cc: Richard Zhu <hongxing....@nxp.com> > > Cc: linux-...@nxp.com > > Cc: linux-arm-ker...@lists.infradead.org > > Cc: linux-kernel@vger.kernel.org > > Cc: linux-...@vger.kernel.org > > Suggested-by: Bjorn Helgaas <helg...@kernel.org> > > I didn't make it very clear, but my suggestion was really to remove > the annotation completely; see below. > > > Signed-off-by: Andrey Smirnov <andrew.smir...@gmail.com> > > --- > > drivers/pci/controller/dwc/pci-imx6.c | 14 +++++++++----- > > 1 file changed, 9 insertions(+), 5 deletions(-) > > > > diff --git a/drivers/pci/controller/dwc/pci-imx6.c > > b/drivers/pci/controller/dwc/pci-imx6.c > > index 59658577e81d..a0510e185d44 100644 > > --- a/drivers/pci/controller/dwc/pci-imx6.c > > +++ b/drivers/pci/controller/dwc/pci-imx6.c > > @@ -362,7 +362,8 @@ static void imx6_pcie_assert_core_reset(struct > > imx6_pcie *imx6_pcie) > > > > switch (imx6_pcie->variant) { > > case IMX7D: > > - case IMX8MQ: /* FALLTHROUGH */ > > + /* fall through */ > > + case IMX8MQ: > > reset_control_assert(imx6_pcie->pciephy_reset); > > reset_control_assert(imx6_pcie->apps_reset); > > break; > > IMO this use of "fall through" is superfluous and unusual in the Linux > source. > > A "fall through" comment would be useful if the IMX7D case had > executable code but no "break". Then the comment shows that the > intent was to execute *both* the IMX7D code and the IMX8MQ code and > the lack of a "break" was intentional. > > In this case, the intent is to treat IMX7D and IMX8MQ the same, and > there's no executable code specifically for the IMX7D. I think it's > easiest to read that when the list of identical cases is all together > without the comment in the middle, i.e., as > > > case IMX7D: > > case IMX8MQ: > > reset_control_assert(imx6_pcie->pciephy_reset); > > rather than this: > > > case IMX7D: > > /* fall through */ > > case IMX8MQ: > > reset_control_assert(imx6_pcie->pciephy_reset);
OK, understood, will remove in next version. Thanks, Andrey Smirnov