Alexey Dobriyan <[EMAIL PROTECTED]> writes: > > That's separate patch but CTL_UNNUMBERED must die, because it's totally > unneeded. If you don't want sysctl(2) interface just SKIP ->ctl_name > initialization and save one line for something useful.
As for the 9p code it doesn't seem to need or want a real binary interface. The 9p debug code picking of a semi-random number and not patching it into sysctl.h like it should for a binary interface is an implementation bug, and a maintenance problem. Further it is a classic example of the silliness that goes on when people actually try and add to the binary interface. So not assigning a binary number very much looks like the right thing to do for 9p. I expect if the change had not happened in a mega patch to 9p that seems to have changed everything the addition of a new user space interface would more likely have been caught in a code review. Now to the issue of using CTL_UNNUMBERED versus knowing that the magic value is zero and we can just leave it uninitialized. I don't much care but given how often people who are not actively watching this mess up I tend to prefer the explicit value. It is a practical question of how do we get the word out that we should not expand the binary interface anymore. The only really practical way I can see us doing better then we are today is to have a separate tree that maps binary numbers into ascii strings and so we remove the ctl_name field entirely from ctl_table. That way people attempting to assign binary numbers using old conventions will have code that doesn't even compile, and the developers themselves are more likely to spot the problem. Eric - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/