Cedric Le Goater wrote: > Pavel Emelianov wrote: >> The set of functions process_session, task_session, process_group >> and task_pgrp is confusing, as the names can be mixed with each other >> when looking at the code for a long time. >> >> The proposals are to >> * equip the functions that return the integer with _nr suffix to >> represent that fact, >> * and to make all functions work with task (not process) by making >> the common prefix of the same name. >> >> For monotony the routines signal_session() and set_signal_session() >> are replaced with task_session_nr() and set_task_session(), especially >> since they are only used with the explicit task->signal dereference. >> >> Signed-off-by: Pavel Emelianov <[EMAIL PROTECTED]> >> Acked-by: Serge E. Hallyn <[EMAIL PROTECTED]> > > please let's get that one in. > > I think we are all ok with it. right ?
Right. That's already the 3rd time I send it to Andrew... > C. > - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/