[cc list restored] Andi Kleen wrote: >> This defines on_cpu() which is similar to smp_call_function_single() >> except that it works if cpu happens to be the current cpu. Can also be >> seen as a complement to on_each_cpu() (which also doesn't treat the >> current cpu specially). >> > > I think it would be better to fix smp_call_function_single to just > handle this case transparently. There aren't that many callers yet because it > is > fairly new. >
Well, smp_call_function_single() is arch specific whereas on_cpu() is generic code. Perhaps rename smp_call_function_single() to __smp_call_function_single() and on_cpu() to smp_call_function_single()? I dislike the loss of symmetry though. -- Do not meddle in the internals of kernels, for they are subtle and quick to panic. - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/