Hi Leonardo,

Thanks for the patch, just some small comments below.

Please, check previous log messages with git log
arch/x86/entry/vdso/vdso2c.h, you will see that most patches had the
prefix "x86/vdso:" in the commit message.

On 10/16/18 9:08 PM, Leonardo Brás wrote:
> Renames the char variable to avoid shadowing a variable previously
> declared on this function.
> 
> Signed-off-by: Leonardo Brás <leobra...@gmail.com>
> ---
>  arch/x86/entry/vdso/vdso2c.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/entry/vdso/vdso2c.h b/arch/x86/entry/vdso/vdso2c.h
> index fa847a620f40..9466998d0f28 100644
> --- a/arch/x86/entry/vdso/vdso2c.h
> +++ b/arch/x86/entry/vdso/vdso2c.h
> @@ -93,11 +93,11 @@ static void BITSFUNC(go)(void *raw_addr, size_t raw_len,
>               int k;
>               ELF(Sym) *sym = raw_addr + GET_LE(&symtab_hdr->sh_offset) +
>                       GET_LE(&symtab_hdr->sh_entsize) * i;
> -             const char *name = raw_addr + GET_LE(&strtab_hdr->sh_offset) +
> +             const char *name2 = raw_addr + GET_LE(&strtab_hdr->sh_offset) +
>                       GET_LE(&sym->st_name);

Could you please use a more meaningful name instead of name2 please? I
believe sym_name should be fine.

>  
>               for (k = 0; k < NSYMS; k++) {
> -                     if (!strcmp(name, required_syms[k].name)) {
> +                     if (!strcmp(name2, required_syms[k].name)) {
>                               if (syms[k]) {
>                                       fail("duplicate symbol %s\n",
>                                            required_syms[k].name);
> 

Regards
Helen

Reply via email to