On Thu, 2007-07-05 at 22:21 -0700, Balbir Singh wrote: > +struct mem_container { > + struct container_subsys_state css; > + /* > + * the counter to account for memory usage > + */ > + struct res_counter res; > +};
How about we call it "memory_usage"? That would kill two birds with one stone: get rid of the comment, and keep people from needing to refer to the comment to figure out what "res" *IS*. > +/* > + * A meta page is associated with every page descriptor. The meta page > + * helps us identify information about the container > + */ > +struct meta_page { > + struct list_head list; /* per container LRU list */ > + struct page *page; > + struct mem_container *mem_container; > +}; Why not just rename "list" to "lru_list" or "container_lru"? > + > +static inline struct mem_container *mem_container_from_cont(struct container > + *cnt) I'd probably break that line up differently: static inline struct mem_container *mem_container_from_cont(struct container *cnt) BTW, do I see "cnt" meaning "container" now instead of "cnt"? ;) Is somebody's favorite dog named "cnt" and you're just trying to remind yourself of them as often as possible? -- Dave - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/