On Sun, Jul 01, 2007 at 07:36:29PM +0400, Oleg Nesterov wrote: > Imho, the current naming of cancel_xxx workqueue functions is very confusing. > > cancel_delayed_work() > cancel_rearming_delayed_work() > cancel_rearming_delayed_workqueue() // obsolete > > cancel_work_sync() > > This looks as if the first 2 functions differ in "type" of their argument > which > is not true any longer, nowadays the difference is the behaviour. > > The semantics of cancel_rearming_delayed_work(dwork) was changed > significantly, > it doesn't require that dwork rearms itself, and cancels dwork synchronously. > > Rename it to cancel_delayed_work_sync(). This matches cancel_delayed_work() > and > cancel_work_sync(). Re-create cancel_rearming_delayed_work() as a simple > inline > obsolete wrapper, like cancel_rearming_delayed_workqueue(). > > Signed-off-by: Oleg Nesterov <[EMAIL PROTECTED]>
Acked-by: Jarek Poplawski <[EMAIL PROTECTED]> - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/