On 2018/9/4 3:04, Borislav Petkov wrote:
It was "Hygon Dhyana" before now "Hygon" only. Can we agree on the
naming nomenclature and stick with it.

OK, agree on it.

...

-       if (!((boot_cpu_data.x86_vendor == X86_VENDOR_AMD) &&
-             (boot_cpu_data.x86 >= 0x0f)))
+       if (!((boot_cpu_data.x86_vendor == X86_VENDOR_AMD &&
+              boot_cpu_data.x86 >= 0x0f) ||
+              boot_cpu_data.x86_vendor == X86_VENDOR_HYGON))

Why are you even touching this statement? The function returns early on
!X86_VENDOR_AMD.

The statement is briefly equal to !(X86_VENDOR_AMD || X86_VENDOR_HYGON).
So the function will not return early on !X86_VENDOR_AMD. :-)

Also the statement can be changed to:
+       if (!(boot_cpu_data.x86_vendor == X86_VENDOR_AMD &&
+             boot_cpu_data.x86 >= 0x0f) &&
+           !(boot_cpu_data.x86_vendor == X86_VENDOR_HYGON))
or:
+       if ((boot_cpu_data.x86_vendor != X86_VENDOR_AMD ||
+            boot_cpu_data.x86 < 0x0f) &&
+           (boot_cpu_data.x86_vendor != X86_VENDOR_HYGON))

Which statement is better?

Thanks,
Pu Wen

Reply via email to