On Thu, 21 Jun 2018, Pavel Tatashin wrote: > diff --git a/arch/x86/kernel/kvm.c b/arch/x86/kernel/kvm.c > index 5b2300b818af..c65c232d3ddd 100644 > --- a/arch/x86/kernel/kvm.c > +++ b/arch/x86/kernel/kvm.c > @@ -628,6 +628,7 @@ const __initconst struct hypervisor_x86 x86_hyper_kvm = { > .name = "KVM", > .detect = kvm_detect, > .type = X86_HYPER_KVM, > + .init.init_platform = kvmclock_init,
Please rename that function to kvm_platform_init(). Other than that: Reviewed-by: Thomas Gleixner <t...@linutronix.de>