On Tue, Jun 12, 2007 at 12:52:25AM +0400, Alexey Dobriyan wrote: > On Mon, Jun 11, 2007 at 09:35:17PM +0100, Christoph Hellwig wrote: > > On Tue, Jun 12, 2007 at 12:40:06AM +0400, Alexey Dobriyan wrote: > > > Identical implementations of PTRACE_PEEKDATA go into > > > simple_ptrace_peekdata() function. > > > > > > compile-tested on ~half of archs, playing with gdb on x86_64. > > > > Looks good. Why don't you call it generic_ptrace_peekdata instead of > > simple_ptrace_peekdata, though? > > Because they're simple :) I was probably spoiled by libfs.c .
The problem with names like 'simple_*' is that, as the years go by, simple code grows to become complex code, and then the prefix 'simple' doesn't apply anymore. Regards, Joe - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/