From: Suren Baghdasaryan <sur...@google.com>

Possible buffer overflow when reading next_read_size bytes into
tmp buffer after next_read_size was extracted from a previous packet.

cc: Stable <sta...@vger.kernel.org>
Signed-off-by: Suren Baghdasaryan <sur...@google.com>
Signed-off-by: Amit Pundir <amit.pun...@linaro.org>
Reviewed-by: Andy Shevchenko <andriy.shevche...@linux.intel.com>
---
v3:
Reset next_read_size to a more readable macro FDP_NCI_I2C_MIN_PAYLOAD
instead of 5.

v2:
Remove redundant __func__ from dev_dgb().

 drivers/nfc/fdp/i2c.c | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/drivers/nfc/fdp/i2c.c b/drivers/nfc/fdp/i2c.c
index c4da50e07bbc..2c5ed2224c5e 100644
--- a/drivers/nfc/fdp/i2c.c
+++ b/drivers/nfc/fdp/i2c.c
@@ -176,6 +176,15 @@ static int fdp_nci_i2c_read(struct fdp_i2c_phy *phy, 
struct sk_buff **skb)
                /* Packet that contains a length */
                if (tmp[0] == 0 && tmp[1] == 0) {
                        phy->next_read_size = (tmp[2] << 8) + tmp[3] + 3;
+                       /*
+                        * Ensure next_read_size does not exceed sizeof(tmp)
+                        * for reading that many bytes during next iteration
+                        */
+                       if (phy->next_read_size > FDP_NCI_I2C_MAX_PAYLOAD) {
+                               dev_dbg(&client->dev, "corrupted packet\n");
+                               phy->next_read_size = FDP_NCI_I2C_MIN_PAYLOAD;
+                               goto flush;
+                       }
                } else {
                        phy->next_read_size = FDP_NCI_I2C_MIN_PAYLOAD;
 
-- 
2.7.4

Reply via email to