* Andi Kleen ([EMAIL PROTECTED]) wrote: > Mathieu Desnoyers <[EMAIL PROTECTED]> writes: > > } > > - profile_hit(SCHED_PROFILING, __builtin_return_address(0)); > > + cond_call(profile_on, > > + profile_hit(SCHED_PROFILING, __builtin_return_address(0))); > > Would it be possible to use a syntax like > > if (unlikely_cond_call(variable)) { (or better name) > ... > } > > instead? I think that would be much nicer to read than having > code in a macro argument >
I see your point, but there is a level of control on the branch I would lack by doing so: the ability to put the call in either the if or else branch. It is an optimization on i386. I could do it by defining my home-made if() : cond_if (cond_call_name) { code } The macro cond_if could then expand (this is a simplified example) in either in if (cond) or if (cond) else Also, I live in the expectation that, someday, the gcc guys will be nice enough to add some kind of support for a nop-based jump that would require code patching to put a jump instead. If it ever happens, my macro could evolve into this for newer compiler versions, which I could not do with the if() statement you are proposing. -- Mathieu Desnoyers Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68 - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/