On Thursday 17 May 2007 03:45:36 am Maciej W. Rozycki wrote: > On Wed, 16 May 2007, Bjorn Helgaas wrote: > > > Given the generic name of "uart" I am assuming this will work with any > > > UART driver making use of the serial_core.c core -- am I correct? > > > > I knew somebody would ask that eventually :-) > > > > Unfortunately, the answer is "no." "console=uart" only works with > > 8250-compatible devices. > > But is it a design limitation or is it just that other UART drivers have > to be modified to work with this option? My point is if the former, then > the option should be something like "console=8250" (the right-hand side > being the name of the driver involved; others may want to add support for > other drivers). If the latter, then it's fine as is as other UART drivers > may be wired to this code as a need arises.
"console=8250" probably would have been a better choice. I think this could be changed without too much hassle. It might be possible to extend "console=uart" so one could do "console=uart,io,0x3f8,9600n8,21285" (where "21285" is a non-8250 UART type). But that seems ugly to me. I'd rather have "console=21285", "console=68328", etc. I just want the "console=<tag>" to explicitly identify the UART type so we don't have to poke at the thing and guess what it is. Bjorn - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/