On Thu, 10 May 2007 12:04:50 -0700 (PDT) Christoph Lameter <[EMAIL PROTECTED]> wrote:
> On Thu, 10 May 2007, Andrew Morton wrote: > > > > > + delayed_cache = kmem_cache_create("dm-delay", > > > > + sizeof(struct delay_info), > > > > + __alignof__(struct > > > > delay_info), > > > > + 0, NULL, NULL); > > > > > > We have an ugly^Wnice new KMEM_CACHE macro for this now. > > How could I nicify the macro? Lower case? Lower case would be worse, IMO. Upper-case says "this is a macro". Lower-case macros are OK when they are macros pretending to be functions, but KMEM_CACHE is not such a thing. I don't think it can be nicified, except by removing it. We generally prefer to open-code things rather than wrapping them up in macros. But given the amount of variation amongst callers and the number of times this got screwed up, I agree that burying those details at a single site makes sense in this instance. - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/