On Tue, May 08, 2007 at 01:22:56PM +0100, David Howells wrote: > Nick Piggin <[EMAIL PROTECTED]> wrote: > > > This patch (along with the subsequent one to optimise unlock_page) reduces > > the overhead of lock_page/unlock_page (measured with page faults and a patch > > to lock the page in the fault handler) by about 425 cycles on my 2-way G5. > > Seems reasonable, though test_and_set_lock_bit() might be a better name.
The postfix attaches lock semantics to the test_and_set_bit operation, so I don't think it is necessarily wrong to have this name. But it doesn't matter too much I guess. > > +There are two special bitops with lock barrier semantics (acquire/release, > > +same as spinlocks). > > You should update Documentation/memory-barriers.txt also. Will do. > > #define TestSetPageLocked(page) \ > > test_and_set_bit(PG_locked, &(page)->flags) > > +#define TestSetPageLocked_Lock(page) \ > > + test_and_set_bit_lock(PG_locked, &(page)->flags) > > Can we get away with just moving TestSetPageLocked() to the new function > rather than adding another accessor? Or how about LockPageLocked() and > UnlockPageLocked() rather than SetPageLocked_Lock() that last looks wrong > somehow. The problem is that it implies some semantics that it may not have. Possibly better is to just remove them all and use only trylock/lock/unlock_page. - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/