On Wed, 2007-05-02 at 21:33 +0200, Rodolfo Giometti wrote: > Pulse per Second (PPS) support for Linux. > > Signed-off-by: Rodolfo Giometti <[EMAIL PROTECTED]> > > --- > > Here my last release of PPS support for Linux. > > The difference against my last patch is about all userland specific > code (timepps.h) which has been removed, I hope now you can consider > adding it into kernel source tree! > > Please, let me know if I still should fix something else.
Please inline your patch, rather then attaching them. It makes it very difficult to discuss when it is attached. > diff --git a/drivers/pps/clients/ktimer.c b/drivers/pps/clients/ktimer.c > new file mode 100644 > index 0000000..7514389 > --- /dev/null > +++ b/drivers/pps/clients/ktimer.c > @@ -0,0 +1,106 @@ > +/* > + * ktimer.c -- kernel timer test client > + * Could you use a better name, like pps_ktimer_test.c, so it is less generic? Same goes for your kabi.c and sysfs.c files. > diff --git a/drivers/serial/8250.c b/drivers/serial/8250.c > index 98ec861..543c7cb 100644 > --- a/drivers/serial/8250.c > +++ b/drivers/serial/8250.c > @@ -2004,6 +2004,8 @@ serial8250_set_termios(struct uart_port *port, struct > ktermios *termios, > up->ier |= UART_IER_MSI; > if (up->capabilities & UART_CAP_UUE) > up->ier |= UART_IER_UUE | UART_IER_RTOIE; > + if (up->port.flags & UPF_HARDPPS_CD) > + up->ier |= UART_IER_MSI; /* enable interrupts */ > This isn't covered by a #ifdef, so is this always safe? Should it be in a separate patch? Unfortunately I don't have any hardware to play with this, but I'd suggest you send this to Andrew Morton for inclusion into his tree for testing. thanks -john - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/