* Ingo Molnar <mi...@kernel.org> wrote: > > + bool changed; > > + __u32 disable[NCAPINTS + NBUGINTS]; > > + unsigned long *disable_mask = (unsigned long *)disable; > > + const struct cpuid_dep *d; > > The constant forced types are really ugly and permeate the whole code. Please > introduce some suitably named helpers in the x86 bitops file that work on > local > variables: > > var &= ~(1<<bit); > var |= 1<<bit;
So instead of adding helpers the 1<< ops can be written out explicitly - they are easy to read after all. Can also be: var &= ~BIT(bit); var |= BIT(bit); Thanks, Ingo