> -----Original Message----- > From: linux-cifs-ow...@vger.kernel.org [mailto:linux-cifs- > ow...@vger.kernel.org] On Behalf Of Long Li > Sent: Wednesday, August 2, 2017 4:11 PM > To: Steve French <sfre...@samba.org>; linux-c...@vger.kernel.org; samba- > techni...@lists.samba.org; linux-kernel@vger.kernel.org > Cc: Long Li <lon...@microsoft.com> > Subject: [[PATCH v1] 22/37] [CIFS] SMBD: Implement API for upper layer to > receive data to page > > /* > + * Read a page from receive reassembly queue > + * page: the page to read data into > + * to_read: the length of data to read > + * return value: actual data read > + */ > +int cifs_rdma_read_page(struct cifs_rdma_info *info, > + struct page *page, unsigned int to_read) > +{
Same comment as for cifs_rdma_write() - this name is confusing as it does not perform an RDMA Read. Needs to be changed. Tom.