On Tue, Jul 25, 2017 at 10:20:50PM -0700, Palmer Dabbelt wrote: > On Tue, 25 Jul 2017 19:57:17 PDT (-0700), j.neuschae...@gmx.net wrote: > > On Tue, Jul 11, 2017 at 06:31:30PM -0700, Palmer Dabbelt wrote: [...] > >> +config ISA_C > >> + bool "Emit compressed instructions when building Linux" > > > > As a user, I'd prefer to have slightly more globally-recognisable names > > than ISA_<single letter> for RISC-V instruction set architecture > > extensions. A quick "git grep -A2 'config ISA'" shows the following > > Kconfig symbols: > > > > * ISA, ISA_BUS_API, ISA_DMA_API, ISAPNP: > > Settings related to the historic ISA bus. > > * ISA_ARCOMPACT/ISA_ARCV2 (arch/arc), > > ISA_M32R/ISA_M32R2/ISA_DSP_LEVEL2/ISA_DUAL_ISSUE (arch/m32r): > > Instruction set options. > > > > Four out of the six instruction set options have ARC/M32R in the name, > > and I think that makes things slightly more readable. Therefore I > > humbly propose something longer, and with a hint of RISC-V in the name, > > such as ISA_RVC. > > > > (Take this with a grain of salt, perhaps.) > > Good timing: I was about to submit a v6 patch set. I'm cool with > CONFIG_ISA_RVC and friends, do you mind submitting a patch?
I'm not sure about ISA_A, because as I understand the mails in one of the previous review threads, RVA is now required by Linux, so there shouldn't be a need for CONFIG_ISA_A (or an equivalent option). CONFIG_RISCV_ISA_C (which Arnd suggested) makes it even clearer that these are RISC-V related options. Here's my patch, for reference (untested, because I currently don't have a riscv compiler installed): Subject: [PATCH] RISC-V: Rename CONFIG_ISA_C to CONFIG_ISA_RVC To make it clearer that ISA_C is a RISC-V related option, rename it to ISA_RVC. Signed-off-by: Jonathan Neuschäfer <j.neuschae...@gmx.net> --- arch/riscv/Kconfig | 2 +- arch/riscv/Makefile | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/riscv/Kconfig b/arch/riscv/Kconfig index cc274bbc29a7..8c43e5c73892 100644 --- a/arch/riscv/Kconfig +++ b/arch/riscv/Kconfig @@ -135,7 +135,7 @@ config TUNE_GENERIC endchoice -config ISA_C +config ISA_RVC bool "Emit compressed instructions when building Linux" default n help diff --git a/arch/riscv/Makefile b/arch/riscv/Makefile index 66c4a5e383f9..7ac91bcf9fe7 100644 --- a/arch/riscv/Makefile +++ b/arch/riscv/Makefile @@ -40,7 +40,7 @@ KBUILD_CFLAGS += -Wall ifeq ($(CONFIG_ISA_A),y) KBUILD_ARCH_A = a endif -ifeq ($(CONFIG_ISA_C),y) +ifeq ($(CONFIG_ISA_RVC),y) KBUILD_ARCH_C = c endif -- 2.11.0
signature.asc
Description: PGP signature