On 29/04/2017 03:39, Geliang Tang wrote:
> Use offset_in_page() macro instead of open-coding.
> 
> Signed-off-by: Geliang Tang <geliangt...@gmail.com>
Acked-by: Richard Genoud <richard.gen...@gmail.com>

> ---
> Changes in v2:
>  - include mm.h
> ---
>  drivers/tty/serial/atmel_serial.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/tty/serial/atmel_serial.c 
> b/drivers/tty/serial/atmel_serial.c
> index c355ac9..d25f044 100644
> --- a/drivers/tty/serial/atmel_serial.c
> +++ b/drivers/tty/serial/atmel_serial.c
> @@ -46,6 +46,7 @@
>  #include <linux/err.h>
>  #include <linux/irq.h>
>  #include <linux/suspend.h>
> +#include <linux/mm.h>
>  
>  #include <asm/io.h>
>  #include <asm/ioctls.h>
> @@ -959,7 +960,7 @@ static int atmel_prepare_tx_dma(struct uart_port *port)
>       sg_set_page(&atmel_port->sg_tx,
>                       virt_to_page(port->state->xmit.buf),
>                       UART_XMIT_SIZE,
> -                     (unsigned long)port->state->xmit.buf & ~PAGE_MASK);
> +                     offset_in_page(port->state->xmit.buf));
>       nent = dma_map_sg(port->dev,
>                               &atmel_port->sg_tx,
>                               1,
> @@ -1141,7 +1142,7 @@ static int atmel_prepare_rx_dma(struct uart_port *port)
>       sg_set_page(&atmel_port->sg_rx,
>                   virt_to_page(ring->buf),
>                   sizeof(struct atmel_uart_char) * ATMEL_SERIAL_RINGSIZE,
> -                 (unsigned long)ring->buf & ~PAGE_MASK);
> +                 offset_in_page(ring->buf));
>       nent = dma_map_sg(port->dev,
>                         &atmel_port->sg_rx,
>                         1,
> 

Thanks !

Reply via email to