* Jiri Slaby <jsl...@suse.cz> wrote:

> This is a start of series to unify use of ENTRY, ENDPROC, GLOBAL, END,
> and other macros across x86. When we have all this sorted out, this will
> help to inject DWARF unwinding info by objtool later.
> 
> So, let us use the macros this way:
> * ENTRY -- start of a global function
> * ENDPROC -- end of a local/global function
> * GLOBAL -- start of a globally visible data symbol
> * END -- end of local/global data symbol

So how about using macro names that actually show the purpose, instead of 
importing all the crappy, historic, essentially randomly chosen debug symbol 
macro 
names from the binutils and older kernels?

Something sane, like:

        SYM__FUNCTION_START
        SYM__FUNCTION_END

        SYM__DATA_START
        SYM__DATA_END

... and extend that macro namespace with any other variants we might need.

We can still keep the old macro names (for a short while) to ease the 
transition, 
but for heaven's sake, if we do "cleanups" before complicating the code let's 
make 
sure the result is actually readable!

Agreed?

Thanks,

        Ingo

Reply via email to