* tip-bot for Waiman Long <tip...@zytor.com> wrote:

> Commit-ID:  c4b73aabd0989d93b82894417ae501690bd1db5e
> Gitweb:     http://git.kernel.org/tip/c4b73aabd0989d93b82894417ae501690bd1db5e
> Author:     Waiman Long <long...@redhat.com>
> AuthorDate: Thu, 5 Jan 2017 15:17:03 -0500
> Committer:  Thomas Gleixner <t...@linutronix.de>
> CommitDate: Sat, 4 Feb 2017 09:01:54 +0100
> 
> debugobjects: Track number of kmem_cache_alloc/kmem_cache_free done
> 
> New debugfs stat counters are added to track the numbers of
> kmem_cache_alloc() and kmem_cache_free() function calls to get a
> sense of how the internal debug objects cache management is performing.
> 
> Signed-off-by: Waiman Long <long...@redhat.com>
> Cc: Christian Borntraeger <borntrae...@de.ibm.com>
> Cc: "Du Changbin" <changbin...@intel.com>
> Cc: Andrew Morton <a...@linux-foundation.org>
> Cc: Jan Stancek <jstan...@redhat.com>
> Link: 
> http://lkml.kernel.org/r/1483647425-4135-2-git-send-email-long...@redhat.com
> Signed-off-by: Thomas Gleixner <t...@linutronix.de>
> 
> ---
>  lib/debugobjects.c | 10 ++++++++++
>  1 file changed, 10 insertions(+)
> 
> diff --git a/lib/debugobjects.c b/lib/debugobjects.c
> index 04c1ef7..d78673e 100644
> --- a/lib/debugobjects.c
> +++ b/lib/debugobjects.c
> @@ -55,6 +55,12 @@ static int                 debug_objects_enabled 
> __read_mostly
>  
>  static struct debug_obj_descr        *descr_test  __read_mostly;
>  
> +/*
> + * Track numbers of kmem_cache_alloc and kmem_cache_free done.

Nit:

   /*
    * Track the number of kmem_cache_alloc()/free() calls done.
    */

Another nit:

> + */
> +static int                   debug_objects_alloc;
> +static int                   debug_objects_freed;

Yeah, so we want to either use past tense consistently:

   static int                   debug_objects_allocated;
   static int                   debug_objects_freed;

Or we want to use present tense consistently:

   static int                   debug_objects_alloc;
   static int                   debug_objects_free;

... but we don't want to mix the two when naming related counters!

( Btw., I'm for the _allocated/_freed pattern, that's what the usual 
nomenclature 
  for statistics counters. )

> +     seq_printf(m, "objects_alloc :%d\n", debug_objects_alloc);
> +     seq_printf(m, "objects_freed :%d\n", debug_objects_freed);

Ditto.

Thanks,

        Ingo  

Reply via email to